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Geometry model of a 3-D Clevis  
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In this exercise you will create an analytic solid model of a clevis by defining MSC⁄PATRAN points, curves, surfaces, solids, and 
a user define coordinate system. Throughout this exercise you will become more familiar with the use of the MSC⁄PATRAN select 
menu. Shown below is a drawing of the model you will build and suggested steps for its construction. 
 

 

Suggested Exercise Steps: 
 

1) Create a new database and name it Clevis.db. 
2) Create a surface model of the top half of the clevis 

as shown in the front view on the right side. Place 
the center of the hole at [0,0,0]. 

3) Create solids that represent the first third of the 
solid model’s total width. 

4) Create the bottom half of your model by mirroring 
all of the solids about the y-axis mirror plane 
located at y=0. 

5) Create the remaining solids that represent the last 
two thirds of your model in the width direction       
(z-direction). 
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In order to create a new database 
You have to do as follows:  

a. File / New... or on a symbol 
New  in Home/Defaults 
section 

b. Enter clevis as the File name 
add Click OK 
 

/ New Model Preference / 
 
c. Select Structural and Click OK 

a 

b 
c 
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Creating a Surface model of a top half of the clevis. 
a. Click on Geometry section 
b. Create -> Point -> XYZ or chose the method from the list, 

enter the value [ 1 0 0] and hit        –Apply- 
c. Go to Preferences->Geometry 
d. Check Exportable to Neutral File and hit Apply 
e. In order to create a curve from the created point select 

Create->Curve->Revolve, in Revolve Parameters  insert 180 
as the value of Total Angle and 4  as a value in section Curves 
per Point 

f. Choose Point 1 and hit –Apply- 
 
The final effect should looks like on the picture above.  

a c 

b 

d 

e 

f 
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You will now use Curvilinear transformation to create the outer 
radius of the lug by radially translating the curves that define a 
quarter of the hole. 
To accomplish this you will first need to create a cylindrical 
coordinate frame located at the center of the hole. 

a. Create->Coord->3point  chose Cylindrical as a Type of 
Coord and hit –Apply- 

b. Transform->curve->Translate check Curvilinear in Refer. 
CF, click on newly created coord - Coord 1 as a reference 
coordinate frame  and Uncheck  Auto Execute . 

c. Show labels by pressing            in Home/Display section. 
d. Insert Curve 1 and Curve 2 to the curve list 
 

In order to choose more than one curve HOLD 
down L.Shift  while selecting curves. 

 

TIP 

a b 

d 
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You have now created all the curves that you will need to 
complete your clevis model. Next, you will create the 
necessary surfaces for the model. You will start by creating a 
4x2 (in x in) Surface that defines part of the upper half of the 
clevis body. 

a. Create->Surface->XYZ insert value <-4 2 0> to define a 
Vector, and [-2 0 0] to define point of origin and hit –
Apply- 

The next series of Surfaces will be created using the Curve 
Method: 

b. Create->Surface->Curve, uncheck Auto Execute and 
select Curve 1 and Curve 2 in a Starting Curve List 
section  and Curve 5 6 as a Ending and hit –Apply- 

Click on           in the Home/Misc.  section to display the lines. 
 
To create the next surface you will use the Select Menu to help 
you define an existing curve and surface edge as the 
boundaries of the new surface. 
 

c. Chose Curve 4 as a Starting Curve, click      and l.click on 
edge 9-10 of a surface 1 and hit –Apply- 

d. Chose Curve 3 as a Starting Curve, click      and l.click on 
Points 8 and 10 while holding l.shift and hit –Apply- 

 

a b 
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You will now use the Surfaces you have just created as patterns to define 
solids (3-dimensional entities) 

a. Create->Solid->Normal ,  insert 0.25 as a Thickness,  Uncheck  Auto 
execute 

b. Chose all surfaces  and click –Apply- 
 
Change the view to Iso 1 in Home/Orientation  section 
 and Fit view  

a 

b 
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Creating the lower part of the clevis 

a. Transform->Solid->Mirror 
b. To Define Mirror Plane Normal click the Coord 0  
c. Click on the Frame Direction 2 on the Select Menu to point out the 

direction of a vector normal to the minor surface. 
d. Uncheck Auto Execute, select all solids Solid 1:5 and press –Apply- 

Click Display Line in Home/Misc. section  

 This way of representing indicates the two important things: 
which Coord is being used and which axis is under consideration 

TIP 

a 

b 

c 

d 
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 <0 0 -0.25> 

 Solid 1 6 

The remaining solids will be created using the translate method. 

a. Transform->Solid->Translate 
b. Enter <0 0 -0.25> in a Direction Vector section 
c. Repeat Count: 2 
d. Uncheck Auto Execute, choose Solid 1 and 6  and press –Apply 

Your last construction step is to 
translate copies of the solids that 
surround the hole to create the final 
solids. Click in the Translation Vector 
databox and click on             in Select 
Menu 

d. To define the translation 
vector, pick Point 10 then 
Point 40 as shown below. Use 
View Corners from Viewing 
to zoom in. After selecting the 
points use Fit View   from 
Viewing to zoom out. 

e. Repeat Count: 1 
f. Select Solids 2 to 5 and 7 to 10 

Solid 2:5 7:10 and hit –Apply- 

To disable the grid View and  enable Body 
press                                            in display                                     
.                                                     menu 

d 

a 

b 

 2 c 

 0.25 
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To save the figure of the geometrical model: 
a) File/Images... 
b) Source: Current Viewport 
c) Choose Increment 
d) Click Apply 

 
A white background of all figures is obligatory. 
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Finite Element Model of a 
3-D Clevis and Property 

Assignment 
 

 

• Apply a non-uniform mesh seed near a critical location of the model. 
• Apply a global mesh to the seeded model. 
• Apply material and element properties.  
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Model Description: 
 

In this exercise you will define a finite element mesh for the Clevis model you developed earlier. You will use mesh seeding to create 
a refine mesh with a higher mesh density near the bottom of the hole where you will apply a force load in a future exercise. 

 

Suggested Exercise Steps: 
 
 

1. Database opening  / creating a new View  
Using an isometric view of your model, zoom in  
on the lower half of the clevis hole. Save this view as 
 a named view. Use the name zoom_in. 
 

2. Create the mesh seeds needed to increase the mesh 
 density in the area where the distributed load will 
 be applied. 
 

3. Create a finite element mesh using the element  
topology and size listed in the diagram on the right. 
 

4. Create an Isotropic material, named Steel which uses a Linear Elastic 
Constitutive Model. The Steel’s Elastic Modulus and Poisson’s Ratio are 
respectively 30E6 and 0.30. 
 
 

5. Create a 3-D element property named, Solid_Elements_Steel, for the entire 
includes the steel material definition 
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1. New View 

Assuming that you have already opened database 
Clevis.db , use the Viewing/ Select Corners          
option to zoom a model in a  specific  area.  

a. Go to Viewing/Named View Option  
b. Create  a new View, name it zoom_in  and hit  

-Apply- 

a 

b 

To simplify the View you 
can always hide or display 
lines by pressing – only 
model’s  boundaries are 
shown. 

TIP 
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2. Creating mesh seeds 

a. Click on Meshing  and as fallows : Create->Mesh seed->One Way Bias  or just 
click on       

b. Insert 6 as a Number (number of seeds on the curve/edge)  and 2 as a L2/L1 
which indicates  seeds  varying size along an edge.  Uncheck  Auto Execute and 
holding L.Shift choose the 1st pair of edges shown in figure and press –Apply- 

Do the same for the 2nd pair of edges but invert the L2/L1 to maintain symmetry of the 
seeds, thus Number: 6, L2/L1: 0.5 and choose 2nd pair of edges and press –Apply- 

In order to select edge  click on               in select menu 

 

1st pair 2nd pair 

This arrow indicates  the 
direction of the edge  

Tip 
a 

b 
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3. Creating Mesh 

a. Create->Mesh->Solid  or simply click on 
b. Change element shape to Hex 
c. Select all solid parts 
d. Uncheck Automatic calculation and insert Value 0.5 

and hit –Apply-  

 

If project is unreadable 
You have to hide Labels  
and decrease the size of 
nodes by pressing in Home 
section:  

Tip a 

b 

c 

d 
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Now that you have created your finite element mesh, it is time to determine whether you need to 
“equivalence the model”. To do this: 

a. Verify->Element->Boundaries,  check the Free Edges and hit –Apply- 

As you can see Your model consist of a group of solids residing next to each other in three dimensional 
space. Since you do not want your model to be in pieces, you must equivalence your model. 
Equivalencing results in all the nodes coexisting in the same location, to be reduced to the node with 
the lowest ID number in that location. 

b. Equivalence->All->Tolerance Cube ,  check the Free Edges  and –Apply- 

You now have one contiguous model of finite elements. To check whether this is true: Repeat the step 
described in point a.   (Your model should looks like the one below at blue background) 

a 

b 
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4. Create an Isotropic material, named Steel, which  
uses a Linear Elastic Constitutive Model. 

a. Click on Properties / Isotropic 
b. Insert Steel  as the name of material and click 

Input Properties   
c. Enter Value 30e6 in Elastic Modulus field and 

0.3 in Poisson’s Ratio and hit OK 
d. Check in Material Status if the steel is in 

ACTIVE material zone press –Apply-  and –
Apply- in Materials  window 

a 

b 

c 

d 
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5. Create a 3-D element property named, Solid_Elements_Steel, or the entire model 
which includes the steel material definition 

a. Properties  Create->3D-> Solid  insert  Solid_Elements_Steel as a Property Set 
Name 

b. Input Properties  Click on         and choose sooner created Steel and hit OK 
c. Click on Select Application Region  mark whole solid click Add-> OK  and –Apply- 

a 

b 

c 
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Loads and Boundary Conditions 
on a 3-D Clevis 

 

Objectives: 
 Apply constraints to your model. 

 
 Create and apply a Pressure 

Suggested Steps: 
1. Create a Pressure case  
2. Create a nodal displacement boundary 

condition named Clambed 
3. Create a Pressure boundary condition  

 

Model Description: 
In this exercise you will create a loading condition and a 
constraint set for the clevis model. The base of the lug will be 
clamped. The hole will be under quadratically varying 
pressure  P = 6900 *(1-x2). 

 

Area  under pressure  

P=6900*(1-x2) 
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8 surfaces 

1. Creating a pressure case (ATTENTION: ‘X, below, is NOT TYPED, it is chosen 
from the list of Independent Variables!!):  

a. Load/BCs // LBC FIELDS->Create spatial function insert Pressure_field  as a 
name check Scalar and Real and insert 6900*(1-‘X**2) as a Scalar Function 
and hit –Apply- 

b.   Element Variable/ Pressure, Enter 
Pressure as a name, change target to 3D 
and click Input Data. 

c.  Double click on Pressure_field  and ok 

d.   Select Application Region -> holding 
L.Shift select all 8 surfaces  than click Add-
> OK and –Apply- 

a b 

c 

d 
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2.  Create a Nodal Displacement boundary condition: 

a. Load/Boundary Conditions  Create-> Displacement 
->Nodal  set name as Clamped 

b. Click on Input data and insert <0,0,0> as a 
Translation and <0,0,0> as a Rotations  and OK 

c. Select Application Region->  change the filter to 
Surface and Add and select surfaces as shown in 
figure, click on Add,  OK  and then –Apply- 

a 

b 
c 
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Display both the displacement 
and force on the finite 
element model: 
a) Display/Load/BC/Elem. 

Props... and check Show on 
FEM only and hit –Apply- 

b) After that, in Loads/BCs tab 
choose Plot markers  as an 
Action 

c) Highlight Displ_Clamped and 
–Apply- . If you want to show 
on the model also a 
pressure, highlight also 
Press_Pressure  before you 
hit –Apply- 
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To save the figure of the finite element model: 
e) File/Images... 
f) Source: Current Viewport 
g) Choose Increment 
h) Click Apply 

 
A white background of all figures is obligatory. 
 



Page 24 of 26 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Run a linear analysis: 

1. Click  Analysis  tab  
2. Set Analysis/Entire Model/ Full Run 
3. Click Solution Type 
4. Check Linear static 
5. Click OK 
6. Click –Apply- 

1 

2 

3 

6 

4 

5 
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Attach the result file,  when the 
analysis job is completed: 

1. Click XDB 
2. Click Select Result File 

and select Clevis .xdb if 
necessary  

3. Click –Apply- 

Bellow there is a fragment of 
the f06 file which contains of all 
in/output data. This fragment 
illustrates distribution of 
the loads. Highlighted value is a 
value of resultant force working 
in Fy direction 

1 

2 

3 
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Post Processing of Stress Results 
 

Objectives: 
 To post-process stress results from MSC/NASTRAN 
 To use MSC/PATRAN to create fill and fringe plots to 

determine if the analyzed part will meet a customer 
defined criteria or whether the part needs to be 

redesigned and re-analyzed. 

 

 

 

 

 

 

 

 

 

 

 



Create 6 different plots with results:

1) Vertical translational displacements in Y direction

2) Von Mises stress σequiv

3) Stress in X direction σx with averaging, continuous σx

4) Stress in X direction σx without averaging, discontinuous σx

5) Stress in X direction σx with averaging, continuous σx for 

the base of the clevis (2 different views)

Set white background:

Cycle Background

Follow the steps (numbers in red frames). 1

2



PLOT no. 1

Vertical translational 

displacements in Y direction

2

3

4

5

6

7

Results -> Create -> Quick Plot

3

File -> Images… -> Apply

1

8

9



PLOT no. 2

Von Mises stress σequiv

4

1 Results -> Create -> Quick Plot

9

2

3

4

5

6

7

8

File -> Images… -> Apply



PLOT no. 3

Stress in X direction σx

with averaging, continuous σx

5

1 Results -> Create -> Fringe

9 2

3

4

5

6

7

8

File -> Images… -> Apply



PLOT no. 4

Stress in X direction σx

without averaging, discontinuous σx

6

1 Results -> Create -> Fringe

8

5

6

7

File -> Images… -> Apply 2

3

4

All Entities 

change to 

None



PLOTS: no. 5 and no. 6
Stress in X direction σ

x

with averaging, continuous σ
x

for the base 

of the clevis (2 different views)

7

1 Results -> Create -> Fringe

2

3

4

5

6

Put cursor in Select Elements

and go to the next slide



8

7

Mark the desired region8

9 Click Apply



9

10 File -> Images… -> Apply

11

12 File -> Images… -> Apply

What is the distribution of

the σx stress at the base of

the clevis along the vertical

direction?



10

Reset Graphics

Check the value of the displacement in the direction Y

of the node located on the lower surface of the hole

at the distance 6 [in]:



1

2

3

Results -> Create -> Cursor -> Vector

this window 

will appear
11

Check the value of the displacement in the direction Y

of the node located on the lower surface of the hole

at the distance 6 [in]:



1 View Corners

2

Mark the desired region

12



Select the desired node

3

13



After selection of the desired node you will see:

Node ID

its 3 components of displacement (XX, YY, ZZ)

1

2

2

1

Read value of YY

14

3



BEAM
Compare the obtained results from the FE analysis (value of YY, previous slide) to

the deflection of the simple model of the beam.

The beam is fixed at one end and loaded by the same value of force as for the clevis.

The material properties for clevis and beam are the same.

P

h

l

15



1. Calculate the deflection of the beam (����� � ⋯).

Data:

� � ⋯	 �� length 

� � ⋯	 �� width 

	 � ⋯	 �� height 


 � ⋯	����

�� � ⋯ ����

� � ⋯	�lbf� resultant load in Y direction (read from the file clevis.f06)

2. Calculate the relative error.

3. Draw conclusions.

BEAM

16



17

Report should also contain:

a) Figures:

1) Geometrical model (1 figure)

2) FE model with load and boundary conditions (1 figure)

3) 6 plots with the results:
• Vertical translational displacements in Y direction

• Von Mises stress σequiv

• Stress in X direction σx with averaging, continuous σx

• Stress in X direction σx without averaging, discontinuous σx

• Stress in X direction σx with averaging, continuous σx for the base of the clevis (2 different views)

Total number of figures = 1 + 1 + 6 = 8

A white background of all figures is obligatory.

A date on the plots with the results is obligatory.

b) Comparison between the obtained results from the FE analysis (value of YY) and

the deflection of the simple model of the beam

- the value of the displacement in the direction Y of the node located on the lower surface of 

the hole at the distance 6 [in]

- formula for the deflection of the beam (���	
 � ⋯)

- data and calculations with proper units

- relative error calculations

c) Conclusions


	Clevis-ribbon 2015_05_18 version 1
	/Suggested Exercise Steps:
	Model Description:
	/Objectives:
	Suggested Steps:
	Model Description:
	Objectives:

	CLEVIS supplement 2015_05_18 version 1

